Jump to content

Erro Compilar Source Server


Recommended Posts

  • Replies 50
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

1 hora atrás, Otresher disse:

gmake -j20

 

por gentileza, poderia postar a linha 133 da makefile?

Deixo aqui o print das linhas do makefile

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

Dá-me este erro ao compilar.

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

Deixo aqui o meu item.cpp para me ajudarem a ver onde está o problema.

Obrigado.

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

Edited by NeverMindz
Link to post
Share on other sites

omg já tinha adicionado o sistema do lennt e agora tenta adicionar outro, sempre com problemas, pegue os arquivos editados e compara com os backups, veja onde falta um } ou ,

aprendam a quebrar a cabeça com coisas simples, isto não devia nem estár em tópico, e o sistema de transmutação do lennt funciona perfeitamente, não entendo por que adicionar outro.

Link to post
Share on other sites
27 minutos atrás, wery disse:

omg já tinha adicionado o sistema do lennt e agora tenta adicionar outro, sempre com problemas, pegue os arquivos editados e compara com os backups, veja onde falta um } ou ,

aprendam a quebrar a cabeça com coisas simples, isto não devia nem estár em tópico, e o sistema de transmutação do lennt funciona perfeitamente, não entendo por que adicionar outro.

Eu estou a adicionar o sistema do lennt, e peço desculpa se não sou um pro no que toca a sources, começei a tratar de sources há razoalvelmente pouco tempo.
Se custa assim tanto ajudar quem precisa mesmo em coisas que parecem simples, basta não ajudar e não criticar...

Obrigado.

Link to post
Share on other sites

como ja disse, compare com o backup, use o beyond compare, veja onde foi adicionado, veja onde falta algum }, não pergunte tudo, tente por si mesmo, não estou criticando, estou dando o conselho de não depender do forum para resolver um } fora do lugar

Link to post
Share on other sites
1 minuto atrás, wery disse:

como ja disse, compare com o backup, use o beyond compare, veja onde foi adicionado, veja onde falta algum }, não pergunte tudo, tente por si mesmo, não estou criticando, estou dando o conselho de não depender do forum para resolver um } fora do lugar

A parte dos } já foi resolvido.. se estivesses atento ao que foi tratado aqui saberias que não é isso que falta resolver... O que falta resolver não fui o único a ter problemas com isto.
Isto é server side source, e ao adicionar como dizia no tutorial há umas linhas que não são compativeis, e modifiquei conforme eu achava que seria. e está a dar erro.
Mas não sei resolver, daí pedir ajuda.

Peço desculpa se incomodo a comunidade com isto.

Link to post
Share on other sites

Meti exactamente igual como o teu, mas dá-me os tais erros de virgulas. Já tentei adicionar "{}" mesmo assim não funcionou. Consegues ver onde errei?

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

Print do erro:

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

Obrigado

Link to post
Share on other sites

Muda:

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

Para:

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

 

No else abres com {, mas depois fechas duas vezes.

Para if de apenas uma linha não é preciso abrir e fechar {}, no entanto como estás a fechar duas vezes, ou abres no if a { , ou eliminas uma antes do break.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...