Jump to content

[Help] Three Major Problems In My Server


Recommended Posts

Hello guys,

I am facing three major problems in my server which is really causing trouble and i need to find out solution for it...

Here they are ..


1) Take Function in quest not working

This is already mention in this thread still cant find solution



2) Guild logo

I have problem with uploading guild logo..*

That is when i add logo to my guild my client crashes and i cant enter again... Server is running.. no syserr in client..

and in server side it shows this error when i upload*

Server Syserr ch1/game





SYSERR: May *3 12:56:30 :: Load: GuildMarkImage: mark/mark_0.tga cannot open file.



Client syserr






invalid idx 0



This error found in MarkManager.cpp in both client and server source..

anyone can solve will be really helpful not only for me but also for others....


Client shows server online but when i enter login at*select character stays at 5 sec and it closes... Whats the problem?


There is mark folder and its empty... when i add mark_0.tga in that folder.. client crashes.. or

when i upload guild logo in my client then mark_0.tga and mark_index is created which causes crashes in client... ... but client crashes when i enter id and password in client ..and logged in..

I guess problem with source either client or server Can anyone find solution for me?


3) Vnum_range in client side..

I added vnum_range for dragon soul system in both source and server db .. But i cant add in client side..

when i dump sql into txt the vnum_range is not in that txt...

DUMP.exe dont have vnum_range..

or how can i add vnum_range manually in client side ?



These 3 errors making me really fed up... I hope i soon get solved by the help of you peoples...


thanks in advance...

Link to comment
Share on other sites

Dump_EXE you have to make your self compiled dump_proto, you can find a src for it at the downloads.


2nd, theres a few options:

Mark server IP equal to the ch1 in the serverinfo.py


Missing folder Mark and respective tga at the ch1core


Devil.DLL corrupted




For the first one, cant help you atm, gonna be without PC for a while

Link to comment
Share on other sites

Hi Tierri I downloaded dump proto source and tried to compile with Visual Studio 2015 community edition.But It shows some upgradation errors.Due to lack of programming knowledge I couldnt correct it.


So I request you to make new dump_proto.exe with vnum_range or dragon soul system.The image below is for reference where vnum_range is in the last.




This dump_proto will be useful for our community members.

Link to comment
Share on other sites

For the second question that is Guild Logo and as per your solution I checked my serverinfo.py and I found the data to be correct which matches with my server and for one information we are not using serverinfo.py.We have implemented a interface where intrologin.py takes care of the channel IP and ports.and I checked that file also.Everything seems OK.But still i am getting this error and client crashes as soon as I upload the guild logo.Inorder to make the server work again I have to delete the contents of mark folder that is mark_0.tga and markindex from server and then I have to reboot once.I am not getting any error on server regarding guild logo but on client syserr I get Invalid Idx 0.Please help

Link to comment
Share on other sites

  • 2 weeks later...
  • 1 month later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...